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Lab Prerequisites  

Following prerequisites and setup must be complete for successful completion of the exercise: 

• You must be connected to the internet. 

• Signup for Power BI: Go to http://aka.ms/pbidiadtraining and sign up for Power BI with a business 

email address. If you cannot sign up for Power BI, let the instructor know. 

• If you have an existing account, please go to http://app.powerbi.com and Sign in using your 

Power BI Account. 

• At minimum, a computer with 2-cores and 4GB RAM running one of the following version of 

Windows: Windows 8 / Windows Server 2008 R2, or later. 

• Microsoft Power BI Desktop requires Internet Explorer 10 or greater.  

• Verify if you have 32-bit or 64-bit operating system to decide if you need to install the 32-bit or 64-

bit applications.  

o Search for computer on your PC, right click properties for your computer.  

o You will be able to identify if your operating system is 64 or 32 bit based on “system type” 

as shown below.  

 

• Download the Power BI Content: Create a folder called DIAD on the C drive of your local machine. 

Copy all contents from the folder called Dashboard in a Day Assets to the DIAD folder you just 

created (C:\DIAD).  

• Download and install Power BI Desktop using any one of the options listed below: 

o If you have Windows 10, use Microsoft App Store to download and install Power BI Desktop 

app.  

o Download and install Microsoft Power BI Desktop from http://www.microsoft.com/en-

us/download/details.aspx?id=45331. 

 

 

 

http://aka.ms/pbidiadtraining
http://app.powerbi.com/
http://www.microsoft.com/en-us/download/details.aspx?id=45331
http://www.microsoft.com/en-us/download/details.aspx?id=45331
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Document Structure  

   This document has two main sections: 

• Power BI Desktop: This section highlights the features available in Power BI Desktop and walks the 

user through the process of bringing in data from the data source, modeling and creating 

visualizations. 

• Power BI Service: This section highlights the features available in Power BI Service including the 

ability to publish the Power BI Desktop model to the web, creating and sharing dashboard and Q & 

A. 

The document flow is in a table format. On the left panel are steps the user needs to follow and in the 

right panel are screenshots to provide a visual aid for the users. In the screenshots, sections are 

highlighted with red boxes to highlight the action/area user needs to focus on. 

 

 

NOTE:  This lab is using real anonymized data and is provided by ObviEnce LLC. Visit their site to learn 

about their services: www.obvience.com .    
This data is property of ObviEnce LLC and has been shared for the purpose of demonstrating Power BI 

functionality with industry sample data.   Any uses of this data must include this attribution to ObviEnce 

LLC.   

http://www.obvience.com/
http://www.obvience.com/
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Overview    
Introduction  
Today you will be learning various key features of the Power BI service. This is an introductory course 

intended to teach how to author reports using Power BI Desktop, create operational dashboards and 

share content via the Power BI Service.   

Data Set   
The dataset you will you use today is a sales and market share analysis.  This type of analysis is very 

common for the office of a Chief Marketing Officer (CMO).  Unlike the office of the Chief Financial Officer 

(CFO), a CMO is focused not only on company’s performance internally (how well do our products sell) but 

also externally (how well do we do against the competing products).  

The company, VanArsdel, manufactures expensive retail products that could be used for fun as well as 

work and it sells them directly to consumers nationwide as well as in several other countries.   

By the end of the class, you will build a report which will look similar to what you have seen in the 

presentation. 
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Power BI Desktop   
Power BI Desktop – Accessing Data  
In this section, you will import VanArsdel and its competitors USA sales data. Then you will import and merge sales 

data from other countries.  

Power BI Desktop - Get Data  
Let’s start with looking at the data files. 

The dataset contains sales data of 

VanArsdel and other competitors. We 

have 7 years of transaction data by day, 

product and zip code for each 

manufacturer. We are going to analyze 

data from 7 countries. 

 

USA sales data is in a csv file located in 

/Data/USSales folder. 

 

Sales of all other countries is in 

/Data/InternationalSales folder. Each 

country’s sales data is in a csv file in this 

folder. 

 

Product, Geography and Manufacturer 

information is in an excel file in 

/Data/USSales/bi_dimensions.xlsx. 

 

1. Open 

/Data/USSales/bi_dimensions.xlsx. 

Notice the first sheet has Product 

information. The sheet has a header and 

product data is in a named table. Also 

notice Category column has a bunch of 

empty cells. 

 

Manufacturer sheet has data laid out 

across the sheet and with no column 

headers and it has a couple of blank rows 

and a note in row 7. 

 

Geo sheet has geography information. 

The first couple of rows has data details. 

Actual data starts from row 4. 
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We will start by connecting to data from 

these different files and perform data 

cleaning and transformation operations. 

2. If you don’t have the Power BI 

Desktop open, launch it now. 

3. Select Already have a Power BI 

Account? Sign in option. 

4. Sign in using your Power BI 

credentials. 

5. Startup screen opens. Click on X on the 

top right corner of the dialog to close 

it. 

 
 
  

Let’s set up the locale to US English, to 

make it convenient to go through the rest 

of this lab. 

 

6. From the ribbon, select File -> Options 

and settings -> Options. 

7. In the left panel of Options dialog, 

select Regional Settings. 

8. From the Locale drop down select 

English (United States). 

9. Select OK to close the dialog. 
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First step is to load data to Power BI 

Desktop. We will load USA Sales data 

which is in comma separated value (CSV) 

files. 

 
10. From the ribbon, select Home -> Get 

Data. 

11. Select Text/CSV. 

 

Note: Power BI Desktop has the 

capability to connect to 100+ data 

sources. We are using csv and excel data 

files in this lab for simplicity. 

  
12. Browse to DIAD\Data\USSales folder 

and select sales.csv.   

13. Click Open. 

 

 

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-data-sources/
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Power BI detects the data type of each 

column. There are options to detect the 

data type based on the first 200 rows or 

based on the entire dataset or not detect 

it. Since our dataset is large and it will 

take time and resources to scan the 

complete data set, let’s leave the default 

option of selecting dataset based on the 

first 200 rows. 

After completing your selection, you have 

three options – Load, Edit or Cancel.   

• Load, loads the data from the 
source into Power BI Desktop for 
you to start creating reports.   

• Transform Data allows you to 
perform data shaping operations 
such as merging columns, adding 
additional columns, changing data 
types of columns as well as 
bringing in additional data.   

• Cancel gets you back to the main 
canvas.   

 
14. Click Transform Data as shown in the 

screenshot. A new window opens. 

 

 
   

 

You should be in the Query Editor 

window as shown in the screenshot to 

the right. Query Editor is used to perform 

data shaping operations. Notice the sales 

file you connected to shows as a query in 

the left panel. You see a preview of the 

data in the center panel. Power BI 

predicts data type of each field (based on 

the first 200 rows) which is indicated next 

to the column header. In the right panel, 

steps that Query Editor performs are 

recorded. 

 
Note: You will be bringing in sales data 

from other countries as well as 

performing certain data shaping 

operations. 

 
15. Notice Power BI has set Zip field to 

data type Whole Number. To ensure 

 
 

 

 

IMPORTANT! 

Changing the 

data type is a big 

deal to use later 
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that Zip codes which start with zero 

don’t lose the leading zero, we will 

format them as text.  Highlight the 

Zip column. From the ribbon, select 

Home -> Data Type and update it to 

Text. 

16. Change Column Type dialog opens. 

Select Replace Current button which 

overwrites Power BI’s predicted 

datatype. 

Now let’s get the data that is in excel 

source file. 

 
17. From the ribbon, select Home -> New 

Source -> Excel. 

    

18. Browse to DIAD\Data\USSales folder 

and select bi_dimensions.xlsx. 

 
Navigator dialog opens. 

 
19. Navigator dialog lists 3 sheets that 

are in the excel workbook. It also lists 

the Product named table. Select 

product from the left panel and in 

preview panel notice the first row is 

the header. This is not part of the 

data. 

20. Unselect product from the left panel. 

Select Product_Table. Notice this has 

only the contents of the named table. 

This is the data we need. 
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Note: Table names are differentiated 

from Worksheet names by using different 

icons. 

21. From the left panel, select geo. In the 

preview panel notice the first couple 

of rows are headers that are not part 

of the data. We will remove them 

shortly. 

22. From the left panel, select 

manufacturer. In the preview panel 

notice the last couple of rows are 

footers that are not part of the data. 

We will remove them shortly. 

23. Select OK. (Make sure Product_Table, 

geo and manufacturer are selected in 

the left panel) 

Notice all 3 sheets are added as queries 

in the Query Editor. 

 

 

Power BI Desktop - Adding additional data  
International subsidiaries have agreed to provide their sales data so that the company’s sales can be analyzed 

together.  You’ve created a folder where they each put their data. 
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To analyze all the data together you will 

want to import the new data from each of 

the subsidiaries and combine it with the 

US Sales you loaded earlier. 

You can load the files one at a time similar 

to the US Sales but Power BI provides an 

easier way to load all the files in a folder 

together.  

 
24. Click on the New Source drop down 

in the Home menu tab of the Query 

Editor. 

25. Select More… as shown in the figure. 

 
Get Data dialog opens.      

26. In the Get Data dialog select Folder as 

shown in the diagram. 

27. Click Connect.  

    

Folder dialog opens. 

28. Click Browse… button. 

29. In the Browse for Folder dialog 

navigate to the location where you 

unzipped the class files. 

30. Open the DIAD folder. 

31. Open the Data folder. 

32. Select the InternationalSales folder. 

33. Click OK (to close the Browse for 

Folder dialog box). 

34. Click OK (to close the Folder dialog 

box). 
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Note: This approach will load all files in 

the folder.  This is useful when you have a 

group that puts files on an ftp site each 

month and you are not always sure of the 

names of the files or the number of files. 

All the files must be of the same file type 

with columns in the same order. 

Dialog displays the list of files in the 

folder. 

 

35. Since we want to combine data, click 

Combine & Transform Data. 

 

Note: Date accessed, Date modified and 

Date created might be different compared 

to the dates displayed in the screenshot. 

 

Combine Files dialog opens. By default, 

Power BI again detects the data type 

based on the first 200 rows. 

Notice there is an option to select various 

file Delimiters. The file we are working 

with is Comma delimited, so let’s leave 

Delimiter option as Comma. 

There is also an option to select each 

individual file in the folder (using Example 

File dropdown) to validate the format of 

the files. 

 

36. Select OK. 
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You will be in the Query Editor window 

with a new query called 

InternationalSales.   

37. If you do not see the Queries pane on 

left, click on the > icon to expand.  

38. If you do not see the Query Settings 

pane on the right as shown in the 

figure, click on View in the ribbon and 

click Query Settings to see the pane.  

39. Click on the Query InternationalSales. 

 

Notice that column Zip is of type Whole 

Number. Based on the first 200 rows 

Power BI thinks Zip is of type Whole 

Number. But zip code could be alpha 

numeric in some countries or leading 

zeros (similar to USA data). If we do not 

change the data type, we will see an error 

when we load the data shortly. So, let’s 

change Zip to data type Text. 

 

40. Highlight the Zip column and change 

the Data Type to Text. 

41. Change Column Type dialog opens. 

Select Replace Current button. 

 

 

In Queries panel, notice Transform File 

from InternationalSales folder is created. 

This contains the function used to load 

each of the files in the folder. 

 

If you compare InternationalSales and 

sales table, you will see the 

InternationalSales table contains two 

new columns, Source.Name and Country. 

 

 

IMPORTANT! 

Changing the data 

type is a big deal 

to use later 
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42. We do not need Source.Name 

column. Select Source.Name column. 

From the ribbon, select Home -> 

Remove Columns -> Remove 

Columns. 

 

 

 

43. Click on the drop down next to 

Country column to see the unique 

values.  

44. You will only see Australia as shown 

in the figure. By default, Power BI 

only loads the first 1000 rows. Click 

on Load more to validate you have 

data from various countries included. 

 

You will see the countries, Australia, 

Canada, Germany, Japan, Mexico and 

Nigeria.  

 

45. Click OK. 

 

Note: You can perform various types of 

filters, sorting operations using the drop 

down to verify the imported data.  
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Power BI Desktop – Data Preparation 
In this section, we will explore methods to transform data in the data model. Transforming the data by renaming 

tables, updating data types, and appending tables together ensures that the data is ready to be used for reporting. 

In some instances, this means cleaning the data up so that similar sets of data are combined. In other instances, 

groups of data are renamed so that they are more recognizable by end users and simplifies report writing. 

Power BI Desktop - Renaming tables 
The Query Editor window should appear 

as shown in the diagram.  

• If formula bar is disabled, you can turn 

on the formula bar from the View 

ribbon. This enables you to see the 

“M” code generated by each click on 

the ribbons. 

• Select the options available on the 

ribbon – Home, Transform, Add 

Column and View to notice the 

various features available.  

 
1. Under Queries panel, minimize 

Transform Files from InternationalSales 

folder. 

2. Select each query name in the Other 

Queries section. 

3. Rename them in the Query Settings -> 
Properties section as shown below: 

 

Initial Name Final Name 

sales Sales 

Product_Table Product 

geo Geography 

manufacturer Manufacturer 

InternationalSales International 
Sales 

  
Note: It is best practice to give descriptive 
query names and column names. These 
names are used in visuals and in Q&A 
section, which is covered later in the lab. 
 

    

 

 

  

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-shape-and-combine-data/
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Power BI Desktop – Filling empty values  
Some of the data provided is not in the right format. Power BI provides extensive transformation capabilities to 

clean and prepare the data to meet our needs. Let’s start with Product query. Notice that Category column has a lot 

of null values. Hover over the green/gray bar (known as quality bar) below the column header. This allows you to 

easily identify errors and empty values in your data previews. Looks like there are values in Category column only 

when the value changes. We need to fill it down to have values in each row. 

4. From the left panel, select Product 

Query.  

5. Select Category column. 

6. From the ribbon select Transform -> Fill 

-> Down. 

 
Notice now all the null values are filled 
with the appropriate Category values. 

 
  

 
 

Power BI Desktop – Splitting columns  
In Product query, notice Product column. Looks like the product name and product segment are concatenated into 

one field with a pipe (|) separator. Let’s split them into two columns. This will be useful when we build visuals, so 

we can analyze based on both fields. 

7. From the left panel, select Product 

Query.  

8. Select Product column. 

9. From the ribbon select Home -> Split 

Column -> By Delimiter. Split Column by 

Delimiter dialog opens. 

10. In the dialog, make sure Custom is 

selected in the Select or enter delimiter 

dropdown. 

Note: Select or enter delimiter dropdown 

has some of the standard delimiters like 

comma, colon, etc. 

11. Notice in the text area, there is a 

hyphen (-). Power BI assumes we want to 

split by hyphen. Remove hyphen symbol 
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and enter pipe symbol (|) as shown in the 

screenshot. 

12. Select OK. 

 

Note: If the delimiter occurs multiple 

times, Split at section provides option to 

split only once (either left most or right 

most) or the column can be split on each 

occurrence of the delimiter. 

 

In this scenario delimiter occurs only 

once, hence Product column is split into 2 

columns. 

 

 

Power BI Desktop – Renaming columns  
Let’s rename the columns. 

13. Select Product.1 column. Right click 

next to the column name. 

14. Select Rename from the selection 

dialog. 

15. Rename the field to Product. 

16. Similarly rename Product.2 to 

Segment. 

 
   

 

Power BI Desktop – Using Column From Examples to split columns  
In Product query, notice that the Price column has price and currency concatenated into one field. To do any 

calculations we just need the numeric value. It will be good to split this field into two columns. We can use the split 

feature like earlier or we can use Column From Examples. Column From Examples is handy in scenarios where the 

pattern is more complex than a delimiter. 
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17. From the left panel, select Product 

Query.  

18. From the ribbon, select Add Column -

> Column From Examples -> From All 

Columns. 

19. In the first row of Column1 enter the 

first Price value which is 412.13 and click 

enter. 

Notice as you enter, Power BI knows that 

you want to split Price column. The 

formula it uses is displayed as well. 

20. Double click column header Text 

After Delimiter to rename it. 

21. Rename the column to MSRP. 

22. Click OK to apply the changes. 

 

 
   

Notice MSRP field is of data type text. It 

must be a decimal. Let’s change it. 

23. Select ABC in MSRP column. 

24. From the selection dialog, select Fixed 

Decimal Number. 

 

Notice all the steps we performed on the 

Product query are being recorded under 

APPLIED STEPS in the right panel.  

 

Similarly, let’s create a currency column. 

25. With Product query selected, from the 

ribbon, select Add Column -> Column 

From Examples -> From All Columns. 

26. In the first row of Column1 enter the 

first Currency value as USD and click enter 

Notice as you enter, Power BI knows that 

you want to split Price column. The 

formula it uses is displayed as well. 

27. Double click column header Text 

Before Delimiter to rename it. 

28. Rename the column to Currency. 

29. Click OK to apply the changes. 
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Now that we have split Price into MSRP 

and Currency columns, we don’t need 

Price column. Let’s remove it. 

30. From the left panel, select Product 

Query.  

31. Right click next to Price column. 

32. Select Remove. 

 

 

Power BI Desktop – Removing unwanted rows  
In Geography query, notice that first two rows are informational. It is not part of the data. Similarly, in Manufacturer 

query the last couple of rows are not part of the data. Let’s remove them so we have a clean dataset. 

33. In the left panel, select Geography 

query. 

34. From the ribbon, select Home -> 

Remove Rows -> Remove Top Rows. 

35. Remove Top Rows dialog opens. Enter 

2 in the text box, since we want to 

remove the top informational data row 

and the blank 2nd row. 

36. Select OK. 

 

Notice the first row in Geography query 

now is the column header. So let’s make it 

a header. 

37. With Geography query selected in the 

left panel, from the ribbon select Home -> 

Use First Row as Headers. 

With that step Power BI predicts data 

type of each field again 

Notice column Zip was changed to data 

type number. Let’s change it to text as we 

did earlier. If we don’t we will see errors 

when we load the data. 

38. Select 123 next to Zip Column. From 

the dialog, select Text. 

39. Select Replace Current in the Change 

Column Type dialog. 

 



 

Version: 12.30.2019                                   Copyright 2019 Microsoft                                                            21 | P a g e  
Maintained by:  Microsoft Corporation    

40. From the left panel, select 

Manufacturer query. Notice the bottom 3 

rows are not part of the data. Let’s 

remove them. 

41. From the ribbon, select Home -> 

Remove Rows -> Remove Bottom Rows 

42. Remove Bottom Rows dialog opens. 

Enter 3 in Number of rows text box. 

43. Select OK. 

 

 

Power BI Desktop – Transposing data 
44. From the left panel, select 

Manufacturer Query. Notice 

ManufacturerID, Manufacturer and Logo 

data is laid across in rows. And the header 

is not useful. We need to transpose the 

table to meet our needs. 

45. From the ribbon select Transform -> 

Transpose.  

 

Notice this transposes the data into 

columns. Now we need the first row to be 

the header. 

 

 
  

46. From the ribbon select Home -> Use 

First Row as Headers. 

 
Notice now Manufacturer table is laid out 
the way we need it with a header and 
values along columns. 
Notice on the right panel under APPLIED 
STEPS you will see the list of 
transformations and steps that have been 
applied.  
You can navigate through each change 
made to the data by clicking on the step. 
Steps can also be deleted by clicking on 
the X that appears to the left of the step.  
The properties of each step can be 
reviewed by clicking on the gear to the 
right of the step.  
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Power BI Desktop – Appending queries  

To analyze the Sales of all countries, it is 

convenient to have a single Sales table. 

Hence you want to append all the rows 

from International Sales to Sales.   

47. Select Sales in the Queries window in 

the left panel as shown in the figure. 

48. From the ribbon select Home -> 

Append Queries. 

Append dialog opens. There is an option 

to append Two tables or Three or more 

tables. Leave Two tables selected since 

we are appending just two tables. 

49. Select International Sales from the 

drop down and click OK. 

 

You will now see a new column in the 

Sales table called Country.  Since 

International Sales had the additional 

column for Country, Power BI Desktop 

added the column to the Sales table when 

it loaded the values from International 

Sales. 

You see null values in the Country column 

by default for the Sales table rows 

because the column did not exist for the 

table with USA data. We will add the 

value “USA” as a data shaping operation.  

50. From the ribbon select Add Column -> 

Conditional Column. 

 

 

51. In the Add Conditional Column dialog, 

enter name of the column as 

“CountryName”. 

52. Select Country from the Column 

Name dropdown. 

53. Select equals from the Operator 

dropdown. 

54. Enter null in the Values text. 

55. Enter USA in the Output text. 

56. Select the dropdown under Else and 

pick Select a column option. 

57. Select Country from the column 

dropdown. 
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58. Click OK. 

This reads, if Country equals null then the 

value is USA else value is that of Country. 

59. You will see the CountryName column 

in the Query editor window. 

 

The original Country column is only 

required as a temporary column. It is 

not required in the final table for 

analysis and can be removed.    

60. Right click on the Country column and 

select Remove as shown in the figure. 

We can now rename CountryName 

column to Country.  

61. Right click on the CountryName 

column and rename to Country. 

62. Using Home -> Data Type or by 

selecting the data type next to the column 

header, change the data type of the 

Country column to type Text. 

63. Using Home -> Data Type or by 

selecting the data type next to the column 

header, change the data type of the 

Revenue column to type Fixed Decimal 

Number since it is a currency field. 

When the data is refreshed, it will process 

through all the “Applied Steps” that you 

have created. 

     

 

The newly named Country column will 
have names for all countries, including the 
USA.  
You can validate this by clicking on the 
drop down next to Country column to see 
the unique values.  
 
64. At first, you will only see USA data. 

Click on Load more to validate you have 

data from all 7 countries.  

65. Click OK to close this filter. 

 



 

Version: 12.30.2019                                   Copyright 2019 Microsoft                                                            24 | P a g e  
Maintained by:  Microsoft Corporation    

Typically, when exploring data, we load a 

subset of data. There are multiple ways to 

do this. From the ribbon, select Home -> 

Keep Rows -> Keep Top Rows OR Home -

> Keep Rows -> Keep Bottom Rows OR 

Home -> Keep Rows -> Keep Range of 

Rows. You can use any of these options to 

filter down to a subset of data. 

Our dataset has data from 2012 to 2018. 

For our analysis we want to start with the 

last 3 years of data (2016-2018). We don’t 

know how many rows. We can filter by 

year to get the subset. 

66. Select the arrow next to Date in Sales 

Query. 

67. Select Date Filters -> In the Previous… 

68. Filter Rows dialog opens. Enter 3 in 

the text box next to is in the previous. 

69. Select years from the dropdown. 

70. Select OK. 

 

 

Now that International Sales data is 
appended to Sales, we don’t need the 
International Sales table to load to the 
data model. Let’s prevent International 
Sales table from loading to the data 
model.  
 
71. From the Queries panel on the left, 

select International Sales query. 

72. Right click and select Enable Load. 

This will disable loading International 

Sales. 

 

Note: The appropriate data from the 

International Sales table will load into the 

Sales table each time the model is 

refreshed. By removing the International 

Sales table, we are preventing duplicate 

data from loading into the model and 

increasing its file size. In some instances, 

storing very large amounts of data affects 

the data model performance. 
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73. From the ribbon select View -> Query 

Dependencies. 

 

This opens Query Dependencies dialog. 

The dialog shows the source of each of 

the queries and dependencies. E.g. We 

see that Sales query has a csv file source 

and it has a dependency on International 

Sales query. This is a useful self-document 

that can be used to share knowledge with 

your team members. 

 

74. Select Close in the dialog. 

 

Query Dependencies view can be zoomed 
in and out as needed. 

 

You have successfully completed import 
and data shaping operations and are 
ready to load the data into the Power BI 
Desktop data model which allows you to 
visualize the data.  
 
75. Click on File -> Close & Apply. 

   

All the data will be loaded in memory 
within Power BI Desktop. You will see the 
progress dialog with the number of rows 
being loaded in each table as shown in 
the Figure.  
 
Note: It may take several minutes to load 
all the tables. 
 
76. Select File -> Save to save the file 

after the data loading is complete. Name 

the file as “MyFirstPowerBIModel”. Save 

the file in \DIAD\Reports folder. 

  

  

 

Power BI Desktop – Data Modeling and Exploration 
In this section, we will learn the key parts of the Power BI desktop, to model and explore the data and build visuals. 

https://powerbi.microsoft.com/en-us/documentation/powerbi-desktop-query-overview/
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Power BI Desktop - Layout   
You will land on the main Power BI 

Desktop window. Let’s get familiar with 

the distinct sections available in the 

Power BI Window. 

 

1. On the top, you see the Home tab 

where the most common operations 

you perform are available. 

2. View tab has options to format the 

page layout.  

3. Modeling tab in the ribbon enables 

additional data modeling capabilities 

like adding custom columns and 

calculated measures.   

4. Help tab provides self-help options like 

guided learning, training videos and 

links to online communities, partner 

showcase and consulting services. 

5. On the left side, you have three icons, 

Report, Data and Model. If you hover 

over the icons, you can see the tool 

tips. Switching between these allows 

you to see the data and the 

relationships between the tables. 

6. The center white space is the canvas 

where you will be creating visuals. 

7. Visualizations panel on the right allows 

you to select visualizations, add values 

to the visuals and add columns to the 

axes or filters. 

 

 

 

 

 

 

 

8. The Fields window on the right panel, 

is where you will see the list of tables 

which were generated from the 

queries. Click the       icon next to a 

table name to expand to the field list 

for that table. 

9. Click on the Data icon. Expand Sales 

table in the Fields as shown in the 

figure 
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Scroll up and down to notice how fast 

you can navigate through ~ 3 Million 

rows.   

10. Click on the Model icon on the left 

panel of Power BI Desktop. 

You will see the tables you have imported 

along with some Relationships. The 

Power BI Desktop automatically infers 

relationships between the tables. 

o A relationship is created between 

Sales and Product tables using 

ProductID column. 

o A relationship is created between 

Product and Manufacturer tables 

using ManufacturerID column. 

Power BI supports 1 to many, 1 to 1 and 

many to many types of relationships 

between the tables.  

In this lab we will be using 1 to many type 

of relationship. This is the most common 

type of relationship between tables. This 

means one of the tables involved in the 

relationship should have a unique set of 

values. 

Notice there is no relationship between 

the Geography and Sales tables. If you 

want to explore sales data across state or 

city or country, you will need to setup the 

relationship between the Geography and 

Sales tables. You will create the 

relationship shortly. 

Note: Tables may not appear as shown in 

the figure. You can zoom in and out of 

the Relationships page by dragging the 

zoom slider in the bottom right corner of 

the window. Also, if want to ensure you 

are seeing all the tables, use the fit to 

page icon: . Drag and move the 

tables to appear as shown in the figure. 

  

  

 

Power BI Desktop – Data Exploration   
 



 

Version: 12.30.2019                                   Copyright 2019 Microsoft                                                            28 | P a g e  
Maintained by:  Microsoft Corporation    

We loaded data from different 

countries. So, let’s start with analyzing 

sales by country. 

11. Click on the Report icon on the left 

panel to navigate to the Report view. 

12. Select the Clustered column chart 

visual in Visualizations as shown in the 

screenshot.  

 

13. From the FIELDS section, expand 

Geography table and click the 

checkbox next to the Country field. 

14. From the FIELDS section, expand 

Sales table and click the checkbox next 

to the Revenue field. 

15. Resize the visual as needed by 

dragging the edges. 

Notice revenue of each country is the 

same. This is because there is no 

relationship between Sales and 

Geography tables. Let’s create one. 

Note: You now need to set up the 

correct relationship between these 

tables.  

To create a relationship between the 

two tables we need a “joining” or 

“relating” column.   

 

16. Click on the Model icon on the left 

panel to navigate to the Relationship 

view. 

17. Sales data is by Zip code. Hence, we 

need to connect Zip column from Sales 

table with Zip column in Geography 

table. You can do this by dragging the 

Zip field in Sales table and connecting 

the line with Zip field in Geography 

table. 

 

You will notice Create relationship 

dialog opens with a warning message 

at the bottom stating the relationship 

has a many-many cardinality. The 
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reason for the warning is that we don’t 

have unique Zip values in Geography. 

This is because multiple countries 

could have the same Zip code. Let’s 

concatenate Zip and Country columns 

to create a unique value field. 

18. Select Cancel in Create relationship 

dialog. 

We need to create a new column in 

both the Geography table and the Sales 

table that combines “Zip” and 

“Country”. Let us start by creating a 

new column in the Sales table.  

19. Click on the Report icon on the left 

panel to navigate to the Report view. 

20. In the Fields section, click on the 

ellipsis next to Sales table. Select “New 

Column” as shown in the figure. 

You will see a formula bar appear as 

shown in the screenshot to help create 

this new column. 

21. We can combine or concatenate 

the Zip and Country columns into a 

new column called ZipCountry 

separated by a comma. Let us create 

this column called ZipCountry using the 

following calculation in the editor. 

 

ZipCountry = Sales[Zip] & "," & 

Sales[Country] 

22. Once you are done entering the 

formula press Enter or click in the 

check mark on the left side of the 

formula bar. 

   
    

 

 

 

 

IMPORTANT! 

If you get an error 

creating a new column 

here, make sure your Zip 

column is the Text Data 

Type. 

If you still have 

problems, ask! 
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You will notice that as you type the 

expression the Power BI desktop guides 

you to choose the right columns using a 

Technology called Intellisense. As you 

type half way through you can select 

the right column by double clicking on 

it using your mouse or by continuing to 

hit tab until you see the correct name.  

The language you used to create this 

new column is called Data Analysis 

Expression (DAX) which is very similar 

to writing expressions in Excel where 

you are concatenating the two 

columns (Zip and Country) in each row 

by using the “&” symbol.  

You will see a new column ZipCountry 

in Sales table. The icon with a (fx) 

indicates you have a column that 

contains an expression, also referred to 

as calculated column.  

You can also create a new column by 

selecting the table and then clicking on 

Modeling -> New Column from the 

ribbon. Let us use this method to 

create a “ZipCountry” column in the 

Geography table.  

 

    

 
 

 

 

 

 

   

23. From Fields section, select 

Geography table and from the ribbon 

select Modeling -> New Column as 

shown in the figure. 

24. Formula bar appears. Enter the 

following DAX expression in the 

formula bar:  

ZipCountry = Geography[Zip] 

& "," & Geography[Country]  

You will see a new column ZipCountry 

in Geography table. The final step is to 

setup the relationship between the two 

tables using the newly created 
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“ZipCountry” columns in each of these 

tables. 

25. Click on the Model icon on the left 

panel to navigate to the Relationship 

view. 

26. Drag ZipCountry field from Sales 

table and connect it to ZipCountry field 

in Geography table. 

Now we have successfully created a 

relationship. The number 1 next to 

Geography indicates it is on the one 

side of the relationship and * next to 

Sales indicates it is on the many side of 

the relationship. 

  

27. Click on the Report icon on the left 

panel to navigate to the Report view. 

Notice the clustered column chart we 

created earlier. It shows different sales 

for each country. USA has the most 

sales followed by Australia and Japan.  

By default, it is sorted by Revenue. 

28. Click on the ellipsis on the top right 

corner of the visual. 

Notice there is option to Sort by 

Country as well.  
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Now let’s analyze Sales by Country by 

Manufacturer and see if we get more 

insights. 

29. With the Clustered column chart 

selected, from the Fields section 

expand Manufacturer table. 

30. Drag and drop Manufacturer field 

to Legend section. 

 

There are many manufacturers and 

clustered column chart does not 

represent the information well. Let’s 

change the visual. 

 

31. With the Clustered column chart 

selected, from the VISUALIZATIONS 

section select Stacked column chart 

visual. 

32. Resize the visual as needed. 

 

Now we can figure out the top 

manufacturers by country. It will be 

nice to narrow down to the top 5 

competitors to better analyze the data.  
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33. With Stacked column chart selected 

34. In the Filters pane, expand 

Manufacturer. 

35. From the Filter Type drop down 

select Top N. 

36. Enter 5 in the text box next to Top. 

37. From Sales table, drag and drop 

Revenue field to By value section. 

38. Select Apply filter. 

 

Notice now the visual is filtered to 

display the Top 5 manufacturers by 

Revenue. We see that VanArsdel has 

higher percentage of sales in Australia 

compared to other countries. 

 

Let’s see if there is another way to 

build this visual. 

39. Click on the white space in the 

canvas and from the ribbon select 

Home -> Ask A Question. 

40. In the dialog start typing Top 5 

Manufacturer. Notice a table with the 

top 5 manufacturers is displayed. 

41. Continue typing Top 5 

Manufacturer by country by revenue. 

Notice a bar chart is created. 

42. Continue typing Top 5 

Manufacturer by country by revenue 

as stacked column chart. Notice we 

can create the same visual we did 

earlier by typing the question. 

43. With the visual selected, under 

VISUALIZATIONS section, scroll down 

to Visual level filters. Expand 

Manufacturer. Notice the Top N filter is 

applied. 

44. We have two of the same visuals, 

so let’s delete this one. Hover over the 

visual and select the ellipsis on the top 

right corner. Select Remove. 
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We are interested in the top 5 

competitors by revenue. Let’s group 

them so we don’t have to add a filter in 

every visual.  

Before we do that let’s remove the Top 

5 visual level filter. 

 

45. With Clustered column chart 

selected 

46. Hover over and select the Clear 

filter icon (erase) next to Manufacturer 

field in the Filters Pane. 

 

47. From the FIELDS section, click on 

the Manufacturer field name (note: do 

not check the checkbox) from 

Manufacturer table. 

48. From the ribbon select Modeling -> 

New Group. Groups dialog opens. 

49. In the Ungrouped values section, 

using Ctrl key, select Aliqui, Currus, 

Natura and Pirum. 

50. Select Group button. Notice a new 

group is added in the Groups and 

members section. 

51. Double click the newly created 

group and rename it to Top 

Competitors. 

52. Select VanArsdel from the 

Ungrouped values section and select 

Group button to create VanArsdel 

Group. 

53. Select the check box Include Other 

group. This will create another Other 

group which will include all the other 

manufacturers. 

54. Select OK to close Groups dialog. 
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55. With the Stacked column chart 

selected, click on the X next to 

Manufacturer in the Legend section. 

This will remove Manufacturer. 

56. From the FIELDS section, drag the 

newly created Manufacturer (groups) 

to the Legend section. 

 

Now we can clearly see that VanArsdel 

has nearly 50% share in Australia.  

 

57. Hover over VanArsdel section of 

the Australia column. You will see a 

tooltip with the Revenue. 

58. Hover over Top Competitors 

section of Australia column to get the 

Revenue value. 

 

Let’s find a better way to view the data 

without creating a new visual. 

 

59. Hover over one of the columns and 

right click. 

60. Select Show Data. 

You will be in Focus mode with the 

chart displayed on top and the data 

displayed below. It is easy to see that 

VanArsdel has a big percent of the 

Australian market. 

61. You can use the icon on the top 

right corner to switch to vertical 

layout. In this layout you will view the 

chart on the left and data on the right 

panel. 

62. Select Back to Report to go back to 

Report canvas. 
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63. There is also an option to see the 

records. Hover over one of the columns 

and right click. 

64. This time select See Records. 

You will see the detailed records. 

65. Select Back to Report to go back to 

Report canvas. 

 

Note: See Records and Show Data 

options are also available in the ribbon 

under Data/Drill menu option. 

 

Let’s create Revenue by Manufacturer 

visual. 

66. Click on the white space in the 

canvas. From the FIELDS section, click 

the checkbox next to Revenue field in 

Sales table. 

67. From the FIELDS section, click the 

checkbox next to Manufacturer field in 

Manufacturer table.  

68. From the VISUALIZATIONS section, 

select Treemap visual.  

69. Resize the visual as needed. 

We have Revenue by Manufacturer. 

Let’s figure out the interaction 

between the Stacked column chart and 

the Treemap visuals.  

70. Click on USA column in the Stacked 

column chart and notice the 

Highlighted section of Treemap 

updates. 

71. Click on Australia column in the 

Stacked Column chart and notice the 

Highlighted section of Treemap 

updates. 

72. Similarly, select VanArsdel in the 

Treemap and notice Stacked column 

chart is filtered. This confirms that  
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VanArsdel has a big percent of the 

Australian market. 

73. To remove the filter select 

VanArsdel again. 

The interaction between visuals is 

called cross filtering. 

Previously we added Top 5 Visual level 

filter. Let’s add a filter to the Page 

level, so we are working with the Top 

Competitors and VanArsdel and filter 

out the other manufacturers. 

Page level filters apply to all the visuals 

on the page whereas Visual level filter 

applies to a visual. 

74. From FIELDS section, drag 

Manufacturer (groups) from 

Manufacturer table to the Filters on 

this page box in the Filters Pane 

75. Select Top Competitors and 

VanArsdel. 
 

Let’s add a visual that will provide sales 

information over time. 

76. Click on the white space in the 

canvas. 

77. Click the checkbox next to the Date 

field in Sales table. Notice a Date 

Hierarchy is created.  

78. Click the checkbox next to the 

Revenue in Sales table field. 

Notice a Clustered column chart is 

created. Also notice in the Axis section, 

a date hierarchy is created. There are 

arrows on the top bar of the chart. This 

is used to navigate through the 

hierarchy. 
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79. Click on the Revenue by Country 

visuals and remove Manufacturer 

(Groups) from the Legend 

80. Click on USA column in the 

Revenue by Country visual. Notice 

sales is on the upward trend over time. 

81. Click on Australia column in the 

Revenue by Country visual. Again, the 

trend is upwards. 

82. We see a similar scenario with 

Japan as well. 

With the current interaction the visuals 

are slicing the data. It will be nice to 

filter data across visuals. This might 

give us a better perspective. Let’s try 

that. 

 

 

83. Click on Australia column in the 

Revenue by Country visual. 

84. With the Revenue by Country visual 

selected, from the ribbon select 

Format -> Edit Interactions.  

Notice on the top right of the other 

two visuals we see new icons with the 

highlight icon selected. 

85. Select filter icon for both visuals. 

Notice now in both Revenue by Year 

and Revenue by Manufacturer data is 

filtered for Australia. 

 



 

Version: 12.30.2019                                   Copyright 2019 Microsoft                                                            39 | P a g e  
Maintained by:  Microsoft Corporation    

86. Now select Revenue by Year visual. 

87. Select filter icon on the other two 

visuals. 

88. Similarly, select Revenue by 

Manufacturer visual and select filter 

icon on the other two visuals. 

Once you are done, all the visuals 

should be in filter mode. 

89. With the Revenue by 

Manufacturer visual selected, from the 

ribbon select Format -> Edit 

Interactions to remove the icons. 

 

90. Click on VanArsdel in the Revenue 

by Manufacturer visual. Notice sales is 

on an upward trend over time. 

91. Click on Natura column in the 

Revenue by Manufacturer visual. 

Notice sales in 2018 for Natura was on 

a downward trend. 

Similarly, you can analyze other 

manufacturers performance. 
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We had already noticed that VanArsdel 

has a big share of the market in 

Australia. Let’s check how VanArsdel 

has done over time in Australia. 

92. Click on VanArsdel in the Revenue 

by Manufacturer visual. 

93. Ctrl+Click Australia column in 

Revenue by Country visual. Now we 

have filtered the charts by both 

VanArsdel and Australia. We see a 

spike in 2018 sales for VanArsdel in 

Australia. 

94. Let’s see what’s happening in USA. 

Click USA column in Revenue by 

Country visual. 

95. Ctrl+Click on VanArsdel in the 

Revenue by Manufacturer visual. Now 

we have filtered the charts by both 

VanArsdel and USA. We see a steady 

growth. 

Similarly, we can analyze data for 

different countries, manufactures and 

time frame.  

 

 

We are intrigued by the spike in 2018 

for VanArsdel in Australia. Let’s 

investigate further. 

96. Click on VanArsdel in the Revenue 

by Manufacturer visual. 

97. Ctrl+Click Australia column in 

Revenue by Country visual 

98. Select the down arrow on the top 

right corner of the Revenue by Year 

visual. This enables drill down 

capability. 

99. Select 2018 column in Revenue by 

Year visual. 

Notice you have drilled down to 

quarter level of 2018. There is a big 

spike in the 4th quarter. Interesting let’s 

dig further… 
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100. Click on the double arrow icon on 

the top right of Revenue by Year 

visual. This drills down to the next level 

of the hierarchy which is month. 

Looks like sales picked up in September 

and October and is holding steady since 

then. Ok this is interesting. Now is this 

a yearly trend. Let’s check? 

101. Click on the up arrow icon on the 

top right of Revenue by Year visual to 

drill up to Quarter level. 

102. Click on the drill up icon again to 

go up to Year level. 
 

103. Click on the split arrow icon on 

the top right of Revenue by Year 

visual. This expands down to the next 

level of the hierarchy which is quarter 

for all the years. 

Notice 4th quarter sales have always 

been high but in 2018 there is a bigger 

spike in the 4th quarter. 

104. Let’s expand down to the month 

level. Click on the split arrow icon on 

the top right of Revenue by Year 

visual. This expands down to the next 

level of the hierarchy which is month 

for all the years. 

There is a lot of information on the 

visual and we must scroll left and right 

to compare.  

105. Click on focus mode icon on the 

top right of Revenue by Year visual.  
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Now Revenue by Year takes over the 

complete canvas. Notice that sales 

have typically been high that last 4 

months of the year. It confirms the 

spike in 2018. 

 

Note: Drill up/down functionality is 

available in the ribbon as well.  

 

106. From the ribbon, select Data/Drill 

-> Drill up to move to Quarter level. 

107. From the ribbon, select Data/Drill 

-> Drill up to move to Year level. 

108. Click on Back to Report on the top 

left corner of the visual to go back to 

report canvas. 

109. Click on VanArsdel in the Revenue 

by Manufacturer visual to remove 

filters. 

 

 

Power BI Desktop – Data Exploration Continued 
In this section, you will continue to 

explore the data to try to identify the 

reasons for the spike in sales in Australia 

for the year 2018. 

At the end of the section, you will create 

a view similar to the view on the right.  
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Let’s continue to investigate our findings 

of VanArsdel’s sales spike in 2018 in 

Australia. We will start by adding a new 

page. 

1. Right click on Page 1 (bottom left). 

2. Select Rename Page. Rename the page 

to Market Analysis. 

3. Right click on Market Analysis page. 

This time pick Duplicate Page. We are 

duplicating the page since we can reuse 

some of the visuals. 

A new page is created, and you will be 

navigated to this new page.  

Let’s add a slicer so we can filter 

manufacturers. 

4. Click on the white space in the canvas. 

From the FIELDS section, click the 

checkbox next to Manufacturer field in 

Manufacturer table.  

5. From the VISUALIZATIONS section 

select Slicer visual. 

6. You will see a list of Manufacturers. 

Select VanArsdel and notice all the 

visuals are filtered based on your 

selection. 

7. Hover over the top right corner of the 

visual and click on the down arrow. 

Notice you have the option to change the 

slicer from a list to a drop down. 

8. Select Dropdown. 

9. Select VanArsdel from the dropdown. 

 

 

10. Navigate to the Market Analysis page. 

In the FILTERS pane click on the X to 

remove the Manufacturer filter from 

Filters on this page. 

Since we have two pages and we want 

Manufacturer filter to apply to both 

pages it makes sense to move it to Filters 

on all pages in the Filters pane. 

11. Navigate back to Duplicate of Market 

Analysis.   
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12. Click on the X to remove the 

Manufacturer filter from Filters on this 

page. 

13. In the FIELDS section, from 

Manufacturer table drag Manufacturer 

(groups) field to the Filters on all pages 

box in the Filters pane. 

14. Select Top Competitors and 

VanArsdel. 

 

We use the Manufacturer slicer to 

analyze one manufacturer at a time. 

Notice when we do this, Revenue by 

Manufacturer Treemap visual is not the 

best representation of the data. Let’s 

change it. 

15. Select Revenue by Manufacturer 

Treemap visual. 

16. From the VISUALIZATIONS section, 

select Card visual. 

 

The card visual will give us the Revenue as 

we filter and cross filter the visuals. 

 

 

Notice all key dimensions/characteristics 

is in its own table with the related 

attributes except date. E.g. Product 

attributes are in Product table and we 

created a relationship between Product 

and Sales. 

It is good practice to have dimensions in 

different tables. In the future if we need 

to add date attributes like Week number, 

Day of Week, Holiday, etc., we need to 

have a Date table. Let’s create Date table. 
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17. Navigate to Data view by clicking on 

the Data icon on the left panel. 

18. From the ribbon select Modeling -> 

New Table. 

Notice a new table is created in the 

FIELDS section on the right and formula 

bar opens. 

19. Enter Date =CALENDAR 

(DATE(2012,1,1), DATE(2018,12,31)) in 

the formula bar and click on the check 

mark. A Date table with a Date column is 

created. 

We are using 2 DAX functions: CALENDAR 

function which takes the start and end 

data. DATE function which takes year, 

month and date fields.  

We are creating Date from 2012 to 2018 

since our dataset has data for those 

years. 

We can add more fields to this table like 

Year, Month, Week etc. by using DAX 

functions. 

Notice Date field is of type Date/Time. 

Let’s change it to data type Date. 

 

20. Select the Date field in the Date table. 

21. From the ribbon, select Modeling -> 

Data type -> Date. 
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Next, we need to create a relationship 

between the newly created Date table 

and Sales table. Previously we used the 

visual drag and drop feature to create a 

relationship. This time around let’s use a 

different option. 

22. From the ribbon, select Modeling -> 

Manage Relationships. 

23. Manage Relationships dialog opens. 

Select New button. 

24. Create relationship dialog opens. 

Select Date from the top dropdown. 

25. Select Sales from the second 

dropdown. 

26. Highlight Date fields from both the 

tables. 

27. Select OK to close Create relationship 

dialog. 

28. Select Close to close Manage 

relationships dialog. 

 

 

29. Navigate to Report view by clicking on 

the Report icon on the left panel. 

Notice Revenue by Date chart looks 

different. Let’s fix it. 

30. Select Revenue by Date visual. 

31. From the Axis click on “X” to remove 

the Date field. 

32. From the FIELDS section expand Date 

table. 

33. Drag Date field to Axis section. 

Notice with the new Date field behavior is 

like earlier. 
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There are two Date fields, it might get 

confusing to figure out which to use. Let’s 

hide the Date field in Sales table. 

34. From the FIELDS section, Click on the 

ellipsis next to Date field in Sales table. 

35. Select Hide. This hides Date field in 

the reports view. We have the option to 

view hidden fields and unhide fields as 

needed. 

36. Similarly hide Country, ProductID, Zip 

and ZipCountry in Sales as well 

 

  

37. Similarly hide ZipCountry from the 

Geography table. 

38. Hide ManufacturerID from 

Manufacturer table. 

39. Hide ProductID and ManufacturerID 

from Product table. 

40.  

Note: It is best practice to hide fields that 

are not used in reports. 
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Let’s get back to our data story, Australia, 

VanArsdel and 2018 – remember 😊. 

Let’s check if the spike occurred in a 

specific region in Australia. 

41. Select Revenue by Country visual. 

42. From the FIELDS section, drag State 

field from Geography table, below 

Country in the Axis section. 

43. Drag District field below State in the 

Axis section. 

We just created a hierarchy. 

 

44. Make sure VanArsdel is selected in 

the Manufacturer slicer. 

45. Enable Drill mode by selecting down 

arrow on the top right corner of Revenue 

by Country visual. 

46. Select Australia to drill down to State 

level. 

47. From Revenue by Year visual select 

2018 and notice Revenue by Country and 

State visual. 

48. From Revenue by Year visual select 

2017 and notice Revenue by Country and 

State visual. 

49. Similarly, select 2016. We don’t see a 

spike in a specific state.  

50. Select 2016 again to remove year 

filter. 

51. Drill up to country level. 
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Let’s analyze by Product to figure out 

what’s happening there. Before we start 

with that let’s create a Product Hierarchy. 

This way we don’t have to drag multiple 

fields to the visual. 

52. From the FIELDS section, click on the 

ellipsis next to Category in Product table. 

53. Select New Hierarchy. 

   

Notice a new field called Category 

Hierarchy is created in the Product table. 

54. Double click on Category Hierarchy 

and rename it to Product Hierarchy. 

 

55. Click on the ellipsis next to Segment. 

56. Select Add to Hierarchy -> Product 

Hierarchy. 

57. Click on the ellipsis next to Product. 

58. Select Add to Hierarchy -> Product 

Hierarchy. 

We have created a Product Hierarchy 

which is Category -> Segment -> Product. 
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59. Click on the white space in the canvas. 

From the VISUALIZATIONS section select 

Clustered bar chart. 

60. From the FIELDS section, expand 

Product table. 

61. Click the checkbox next to Product 

Hierarchy. Notice complete hierarchy is 

selected. 

62. From the FIELDS section, expand 

Sales table. 

63. Click the checkbox next to Revenue 

field. 

 

Note: Make sure you have VanArsdel 

selected in the slicer. 

We see that VanArsdel has a presence in 

the Urban category and a small presence 

in the Rural category. 

64. Drill down Urban category (yes you 

are an expert drilling up and down 

hierarchy 😊). If not, select the down 

arrow on the top right corner of the 

visual. 

65. Select the Urban row to drill down to 

Urban segments. 

  

66. In Revenue by Country visual select 

USA. 

67. Ctrl+Click 2018 from Revenue by Year 

visual. Notice Convenience and 

Moderation are the key segments in USA. 
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68. In Revenue by Country visual select 

Australia. 

69. Ctrl+Click 2018 from Revenue by Year 

visual. Notice sales in Extreme category is 

higher than Convenience and Moderation 

segments. 

We need to investigate further… 

 

70. Select the down arrow on the top 

right corner of Revenue by Country visual 

to enable drill model. 

71. Select Australia to drill down to State 

level. 

72. Select 2018 in Revenue by Year visual. 

73. Remove drill mode from Revenue by 

Category visual. 

74. Ctrl+Click Extreme Segment in 

Revenue by Category and Segment visual. 

75. Select 2017 in Revenue by Year visual. 

76. Ctrl+Click Extreme Segment in 

Revenue by Category and Segment visual. 

 

There is no significant spike by State. 

 

77. Select Extreme again to remove cross 

filtering between visuals. 

78. Drill up to Category level in Revenue 

by Category visual. 
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Let’s add a Matrix visual so we can view 

data in rows and columns. We can apply 

conditional formatting to the matrix 

visual to highlight outliers. 

 

79. Click on the white space in the canvas. 

From the VISUALIZATIONS section, select 

Matrix visual. 

80. From FIELDS section, drag and drop 

Product Hierarchy field from Product 

table to Rows section. 

81. From Sales table in FIELDS drag and 

drop Revenue to Values section. 

 

Note:  Notice Revenue field needs to be 

formatted so it shows the same number 

of decimal points. We will do this shortly. 

  

 

82. Enable drill mode in the matrix by 

selecting the down arrow on the top right 

corner of the visual. 

83. Select Urban row to drill down. 

 

   

Well the text is too small, let’s format the 

matrix and make it more readable. 

84. In the VISUALIZATIONS panel, select 

the paint roller icon to format the visual. 

85. Scroll down and expand Values 

section. 

86. Scroll down and increase the Text 

size to 12. 

Notice there are a lot of formatting 

options. Feel free to explore them. 

87. Scroll up and expand Column headers 

section. 

88. Scroll to Text size and increase it to 

12. 

89. Scroll up and expand Row headers 

section. 

90. Scroll to Text size and increase it to 

12. 
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Let’s add percent of total field. This will 

give us a better perspective. 

91. Navigate away from Format section to 

the Fields well. 

92. From FIELDS section drag Revenue 

field from Sales table below the existing 

Revenue field in Values section. 

93. Select the arrow next to the newly 

added Revenue field. 

 

94. From the dialog select Show value as 

-> Percent of grand total. 

 

We see that in Australia, Extreme 

segment has highest market share. Let’s 

check across time if this is true. 

 

95. In the Revenue by Year visual select 

2016 column. Notice Extreme segment 

has around 30% of the grand total.  

96. In the Revenue by Year visual select 

2017 column. Notice Extreme segment 

has around 30% of the grand total. 

97. In the Revenue by Year visual select 

2018 column. Notice Extreme segment 

has around 40% of the grand total. 

98. In the Revenue by Year visual select 

2018 column to remove the filter. 

 

Let’s drill down Extreme Segment and 

figure out if a Product stands out. 
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99. In the matrix visual select Extreme 

row to drill down to Product level. 

100. Resize the visual as needed. 

101. Hover over matrix visual and select 

the ellipsis on the top right corner.  

102. Select Sort By %GT Revenue and 

Sort Descending. 

 

We see the top Products. Let’s analyze 

top Products over time. 

 

103. In the Revenue by Year visual select 

2016 column. Notice Maximus UE-04 and 

11 are the top products.  

104. In the Revenue by Year visual select 

2017 column. Notice Maximus UE-16 and 

17 are the top products. 

105. In the Revenue by Year visual select 

2018 column. Notice Maximus UE-04 and 

21 are the top products. And Product 04 

has nearly 7% of the grand total. Product 

04 has a big spike. 

106. In the Revenue by Year visual select 

2018 column to remove the filter. 

 



 

Version: 12.30.2019                                   Copyright 2019 Microsoft                                                            55 | P a g e  
Maintained by:  Microsoft Corporation    

Earlier we created a calculated column 

(ZipCountry). Let’s create % Growth 

measure so we can compare sales over 

time. We are going to do this in two 

steps. 

 

But first, what’s the difference between 

measure and calculated column. 

Calculated column is evaluated row by 

row. We extend a table by adding 

calculated columns. 

Measure is used when we want to 

aggregate values from many rows in a 

table. 

107. In the FIELDS section, select Sales 

table. 

108. From the ribbon, select Modeling -> 

New Measure. Formula bar opens. 

109. Enter PY Sales = 

CALCULATE(SUM(Sales[Revenue]), 

SAMEPERIODLASTYEAR('Date'[Date])) 

110. Select the check mark next to the 

formula bar. You will see PY Sales 

measure in Sales table. 

  

 

Let’s create another measure. 

111. In the FIELDS section, hover over 

Sales table. 

112. Click on the ellipsis on the right 

corner. 

113. Select New Measure from the 

dialog. Formula bar opens. 

114. Enter % Growth = 

DIVIDE(SUM(Sales[Revenue])-[PY 

Sales],[PY Sales]) 

115. Select the check mark next to the 

formula bar. You will see % Growth 

measure in Sales table. 
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116. Select the matrix visual. 

117. In the FIELDS section, click the 

checkbox next to the newly created PY 

Sales and % Growth measures in Sales 

table. 

Notice fields need to be formatted. 

118. From the FIELDS section, select % 

Growth field. 

119. From the ribbon select Modeling -> 

Format -> Percentage 

120. Similarly, from the FIELDS section, 

select PY Sales field. 

121. From the ribbon select Modeling -> 

Format -> Currency -> $ English (United 

States) 

122. Similarly, from the FIELDS section, 

select Revenue field. 

123. From the ribbon select Modeling -> 

Format -> Currency -> $ English (United 

States) 

 

 

124. In the Revenue by Year visual select 

2018 column. Notice Maximus UE-04 has 

nearly 158% growth compared to last 

year. 
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125. Select Matrix visual. 

126. From the Values section, select the 

arrow next to % Growth. 

127. Select Conditional Formatting -> 

Icons. 

 

Note: Conditional formatting can be 

applied using font color, background color 

or data bars as well. 

 

Icons - % Growth dialog opens. Notice 

there are options to pick icon style, 

layout, alignment. You can Format by 

rules or fields. 

 

128. Select OK. Notice conditional 

formatting is applied. 

 

Let’s change conditional formatting to use 

Background color. 

 

129. With Matrix visual selected, from 

the Values section, select the arrow next 

to % Growth. 

130. Select Remove Conditional 

Formatting -> Icons. 
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131. With Matrix visual selected, from 

the Values section, select the arrow next 

to % Growth. 

132. Select Conditional Formatting -> 

Background Color. 

 

 

Background color dialog opens. This 

dialog provides options to format 

background color either using rules or 

diverging colors. 

 

133. Select the Diverging checkbox. 

134. Select OK. 

 

Note: Conditional formatting can also be 

based on another column using Color 

based on drop down. 

 

  

 

 

Power BI Desktop – Data Visualization  
 

Having done the data exploration and visualization you have found good insights to share with your team. In this 

section, you will create a professional report from which you and your entire team can benefit.  
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At the end of this section, you will build a 

report like the one shown in the 

screenshot. 

 

Let’s remove Revenue by Category 

clustered bar chart. 

1. Hover over Revenue by Category 

visual. 

2. From the top right corner select the 

ellipsis 

Select Remove to delete the visual. 

 

Initially we added a filter to load 3 years 

of data. Let’s load the complete data. 

3. From the ribbon, select Home -> Edit 

Queries. Power Query Editor window 

opens. 

4. From the left panel, select Sales query. 

5. From the right panel, under APPLIED 

STEPS click on the X next to Filtered Rows 

to remove the 3-year filter. 

6. Select Home -> Close & Apply to load 

the data.  

7. Sales data is reloaded, this time all the 

data is loaded. It might take a couple of 

minutes as we are loading ~7 million 

rows. 
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Make sure the report is filtered by 

VanArsdel using Manufacturer slicer. 

Remove all other filters. 

 

At this point your report page should look 

something like the screenshot. 

Once data is loaded, notice Revenue by 

Year visual. You will see columns for 

years 2012 through 2018. 

 

Let’s add a Date slicer so we can control 

how many years of data we want to 

analyze. 

8. Click on the white space in the canvas. 

From the VISUALIZATIONS section, select 

Slicer visual. 

9. From FIELDS section, click the 

checkbox next to Date field in Date table.  

Notice we have a range slicer with a 

slider.  

Move the slicer to filter the data to 

1/1/2014 to 12/31/2018 or type in the 

values. 
 

10. Hover over the date slicer. 

11. Select the arrow from the top right 

corner. Notice following options are 

available – Before, After, List, Dropdown 

and Relative. Feel free to try out the 

various options. 

12. Select Relative. Notice this has 

options to filter data by the Last x years, 

months, days or Next x years, months, 

days, etc. Feel free to try out various 

options.  
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13. Hover over Manufacturer slicer 

visual. 

14. On the top right corner select the 

arrow.  

15. Select List. 

16. in VISUALIZATIONS panel select the 

paint roller icon. This opens the 

formatting options available for a visual. 

17. Expand General section, select 

Horizontal from the Orientation 

dropdown. 

18. Notice the Slicer visual is updated. 

You can resize the visual, so all the 

manufacturers are listed horizontally. 

Note: There are other options to change 

the Outline color, weight, etc. 

19. Select VanArsdel. 

20. Collapse General section. 

21. Note: Expand Selection Controls 

section. Notice there is an option to 

enable Select All option in the visual. 

There is also an option to make the slicer 

multi select. Feel free to explore other 

formatting options. 

 

It will be nice to add logos of the 

manufacturer to the slicer. Let’s do it. 

22. From FIELDS section, select Logo field 

from Manufacturer table. 

23. From the ribbon, select Modeling -> 

Data Category -> Image URL. Setting data 

category to Image URL helps Power BI to 

understand that it is a URL and it can 

access the data. 
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24. From the canvas, select Manufacturer 

slicer. 

25. From FIELDS section, drag and drop 

Logo from Manufacturer table to Field 

well. 

26. Select Logo field. 

27. Resize slicer visual as needed. 

28. Select VanArsdel logo to filter all the 

other visuals. 

  

 

29. Select Revenue by Year visual. 

30. From VISUALIZATIONS panel, select 

Line and clustered column chart to 

change the visual type. 

31. From FIELDS section, drag and drop % 

Growth field from Sales table to Line 

values. 

 

This provides a representation of the 

revenue and growth over time.  

 

32. Select Revenue Card visual. Let’s 

change this to a Gauge visual. 

33. From VISUALIZATIONS panel, select 

the Gauge visual. 

34. From FIELDS section, drag and drop 

PY Sales field to Target value. 

Resize the visual as needed. Now we can 

compare Revenue with the target. 

 



 

Version: 12.30.2019                                   Copyright 2019 Microsoft                                                            63 | P a g e  
Maintained by:  Microsoft Corporation    

It will be nice to change the colors on the 

visuals.  

35. Select Gauge visual. 

36. From VISUALIZATIONS panel, select 

paint roller icon. 

37. Expand Data Colors section. 

38. Select the arrow next to Fill color. 

 

39. Notice you can pick a color from the 

default color palette or pick Custom 

colors. 

 

Let’s check out some of the themes 

available. 

40. From the ribbon, select Home -> 

Switch Theme -> Temperature. 

Notice colors on all the visuals updated. 

Feel free to try the other out of the box 

themes. 

 

Marketing department has provided 

standard color themes to be used across 

reports. We can use Report Theme 

feature in Power BI by uploading a theme. 

Report Theme requires a JSON file where 

the data colors, background, foreground 

and table Accent colors are defined. The 

JSON file can be used across all the 

reports. 

41. From the ribbon, select Home -> 

Switch Theme -> Import Theme. 

42. File browser dialog opens. Navigate to 

/Data/Theme folder. 

43. Select DIADTheme1 file and select 

Open. 

Once theme is imported, a success dialog 

opens. Select Close. 
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Notice colors on all the visuals updated. 

Your report should look something like 

the screenshot at this point. 

This one is good, but too much red in it. 

Marketing team has provided one more 

theme, let’s try it. 

44. From the ribbon, select Home -> 

Switch Theme -> Import Theme. 

45. File browser dialog opens. Navigate to 

/Data/Theme folder. 

46. Select DIADTheme2 file and select 

Open. 

47. Once theme is imported, a success 

dialog opens. Select Close. 

 

Notice colors on all the visuals updated. 

Your report should look something like 

the screenshot at this point. 

 

This theme looks good. Now most of the 

visuals are blue in color, let’s add some 

contrast. 

 

48. Select the Gauge visual. 

49. From VISUALIZATIONS panel, select 

paint roller icon. 

50. Expand Data colors section. 

51. Select the drop down next to Target. 

Notice the color palette is different now. 

Select black color. Notice the change in 

the visual. 
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52. Collapse Data colors section. 

53. Expand Data Labels section. 

54. Increase Text size to 10. 

55. Expand Target section. 

56. Increase Text size to 10. 

 

57. Select Matrix visual. 

58. Drill up to Segment level. 

59. Select Revenue by Country visual. 

60. Drill up to Country level. 

61.  From VISUALIZATIONS panel, select 

paint roller icon. 

62. Expand Data colors section. 

63. Select a light shade of gray as the 

Default color. 

64. Enable and expand Data labels. 

65. Change Display units to Millions. 

 

66. Notice there a lot of formatting 

options. E.g. visual title can be changed 

and formatted, you can add a border and 

background to the visual, etc. Feel free to 

explore the options. 

 

 

67. Select Revenue and % Growth by 

Year visual. 

68. From VISUALIZATIONS panel, select 

paint roller icon. 

69. Expand Data colors section. 

70. Select black color for % Growth. 

Select a light shade of gray as the Default 

Column color. 
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Let’s add a report title. 

71. From the ribbon, select Home -> Text 

box. Notice a text box visual is added. 

72. Resize the visual as needed. 

73. Enter Manufacturer Analysis in the 

Text box. 

74. Highlight Manufacturer Analysis to 

format the text.  

75. Select Segoe (Bold) as the font. 

76. Select 36 as the font size. 

77. Resize the text box as needed. 

 

 

78. From the ribbon, select View. 

79. Select the checkbox next to Show 

Gridlines and Snap Objects to Grid. This 

will help with aligning the visuals. 

80. Move and align the visuals like the 

screenshot. As you move visuals notice 

the red smart guide helps aligning them. 

Uncheck Show Gridlines and Snap 

Objects to Grid options to disable these 

features. 

81. Rename the page to Manufacturer. 

 

We can also use a background image to 

format the reports. Let’s try it. 

82. Select + icon in the bottom of the 

page to create a new page. You will be 

navigated to a Page 1. 

83. Click on the white space in the 

canvas. 

84. From VISUALIZATIONS panel, select 

paint roller icon. 

85. Expand Page Background section. 

86. Select Add Image button. 

87. File browser dialog opens. Browse to 

/DIAD/Data folder. 

88. Select Background file. 

Select Open. 
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89. From Image Fit drop down, select Fit. 

90. Slide Transparency slider to 0%. 

Notice we have a template which has 

place for header and slots for images. 

91. Navigate to Manufacturer page.  

92. Select Revenue by Country visual. 

93. From the ribbon select Home -> Copy. 

94. Navigate to Page 1. 

95. From the ribbon select Home -> 

Paste. 

96. Resize the visual and place it as 

shown in the screenshot. 
 

97. Navigate to Manufacturer page.  

98. Select Manufacturer slicer. 

99. From the ribbon select Home -> Copy. 

100. Navigate to Page 1. 

101. From the ribbon select Home -> 

Paste. 

102. Sync visuals dialog opens. Select 

Sync.  

This will keep Manufacturer slicer in both 

the pages in sync. Changing slicer in one 

of the pages will update visuals in both 

the pages. 

103. Resize the slicer and place it as 

shown in the screenshot. 

 

 

104. Similarly, copy the report title, 

gauge, matrix and the line and clustered 

column visual. 

105. Resize and arrange the visuals as 

shows in the screenshot. 
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Let’s add a logo. 

106. From the ribbon, select Home -> 

Image. 

107. File browser dialog opens. Browse to 

/DIAD/Data folder. 

108. Select VanArsdel_Logo file. 

109. Select Open. 

110. Resize the visual as needed. 

111. Drag the visual to the top left corner 

of the page. 

112. Note: The logo is transparent. You 

need to place it on the blue background 

to see it. 
 

Let’s change the font color of report title.  

113. Highlight Manufacturer Analysis. 

114. Select the arrow next to A for font 

color. 

Select white color. 

  

Out of the box, Power BI has a good 

selection of visuals. However, there is 

always a use-case where you need a 

custom visual. To meet this need, the 

visualization engine is open sourced. 

Power BI community contributes visuals 

which are available in the marketplace. 

You can add and use these visuals in your 

reports. 

There is also an option to create your 

own visual and import it into Power BI 

Desktop. 

Let’s add a custom visual.  

115. From VISUALIZATIONS section, 

select the ellipsis in the last row of 

visuals. 

116. Select Import from marketplace. 

117. Type play axis in the search box and 

select search. 

118. Select Add next to Play Axis 

(Dynamic Slicer). 

Note: Notice the checkmark in the blue 

star. This sign is used to identify certified 
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custom visuals. Custom visuals that meet 

Power BI teams coding requirements are 

certified. Certified custom visuals support 

features like export to Power Point, ability 

to display in subscription emails which is 

not supported by non-certified custom 

visuals. 

119. Import custom visual dialog opens. 

Select OK. 

120. Notice a new visual is added to the 

list of available visuals. 

121. Click on the white space in the 

canvas. 

122. From VISUALIZATIONS section, 

select the newly imported Play Axis 

visual. 

123.  From FIELDS section, click the 

checkbox next to Date field in Date table. 

124. From VISUALIZATIONS panel, select 

paint roller icon. 

125. Expand Colors section. 

126. Enable Show all option. 

Resize and position the visual as shown in 

the screenshot.  

 

127. Enable drill mode in matrix visual. 

128. Select Extreme category to drill 

down to Extreme products. 

129. Select Play in the Play axis visual. 

Notice all the visuals update as play axis 

moves through years. You can view 

Product performance over time as well as 

performance of countries over time. Play 

axis provides an option to analyze data 

over time (or any other dimension) across 

all visuals in the page. 

130. Once you are done playing through 

the years, in the matrix visual drill back 

up to Product Category level. 

131. Disable drill mode in matrix visual. 

132. There are a lot of custom visuals 

available and new ones are added 

periodically. 
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Now we have a report ready, let’s use 

Bookmarks to tell the story we 

discovered. Bookmarks capture the 

currently configured view of a report 

page, including filtering and the state of 

visuals which makes it easy to present the 

story. 

133. From the ribbon, select View. 

134. Select the checkbox next to 

Bookmarks Pane to enable Bookmarks. 

BOOKMARKS pane opens. 

135. Click on Add in BOOKMARKS pane. 

This will add the current state of the 

visual to the bookmark. 

136. Click on the ellipsis next to the 

newly created Bookmark 1. 

Select Rename to rename it to Initial 

State 

 

 

137. In Revenue by Country visual, select 

USA column. 

138. Hover over Revenue by Country 

visual and select the ellipsis on the top 

right corner. 

139. Select Spotlight. 

140. In the BOOKMARKS pane, select 

Add. This will add a new bookmark with 

the current state of the report.  

141. Click on the canvas. 

142. Select Australia in Revenue by 

Country visual. 

143. In the BOOKMARKS pane, select 

Add. This will add a new bookmark with 

the current state of the report. 
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144. From the BOOKMARKS pane, select 

View. You are in Bookmarks slide show 

mode. 

You will be in the first bookmark which 

we called Initial State. Notice on the 

bottom of the report pane there is an 

option to navigate between bookmarks. 

145. You can use the arrows to navigate 

between bookmarks and tell your story. 

146. From BOOKMARKS pane, select Exit 

to exit Bookmarks slide show mode. 

 

147. If time permits, feel free to explore 

other options available with Bookmarks 

like Selected Visuals and more as you 

continue to build the story.   

148. From the ribbon, select View. 

149. Uncheck Bookmarks Pane. 

150. Collapse the Visualizations and 

Filters pane by clicking on the arrows. 

Report should look as shown in the 

figure. Save the file. 

151. Select File -> Save. 

 

You have built your first report!!! 

 

152. Navigate to /DIAD/Reports folder. 

153. Open DIAD Final Report.pbix file.  

 

This file uses the same dataset that you 

used for the lab. We have added a few 

more visuals and formatted the reports. 

Feel free to explore the report. 
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You have successfully completed the hands-on lab in creating a report to share to your team. The next 

section covers creating a dashboard from this report so that you can easily share it to your team. You have 

learned a quick overview of various functionality in Power BI Desktop to get accelerated. There are a lot 

more features for you to build upon this on your own data.   
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Power BI Service  
  

You will now leverage the report authored using Power BI Desktop and create a dashboard for VanArsdel data 

analysis team and share it with the CMO. A Power BI Desktop file with additional reports / visuals is provided. Please 

use this for the next section of the lab.  

Power BI Service – Publishing Report  
 

1. If you have not signed up for a Power 

BI account, go to 

http://aka.ms/pbidiadtraining and sign up 

for Power BI with a business email 

address.  

2. If you have not already opened 

app.powerbi.com page, please open the 

browser and navigate to 

http://app.powerbi.com. 

3. Sign in to Power BI using your user 

account. Once logged in, you will be 

navigated to the Home screen. 

Note: If you have previously signed into 

Power BI, then your Home screen will list 

your Favorites + frequents and recent 

reports and dashboards. 

 

 
 

4. If the left navigation is collapsed, 

select  icon below Power BI on the 

top left of the screen to expand the left 

navigation. 

Following options are listed in the left 

navigation: 

Home: This is one-stop shop for all     

your content. It lists your favorite 

and recent content (reports, 

dashboards and apps), as well as the 

latest content that was shared with 

you, etc. 

Favorites: Lists all your favorite 

content (we will create a favorite in a 

later section). 

Recent: Lists the most recent content 

you have viewed. 

  

http://aka.ms/pbidiadtraining
http://app.powerbi.com/
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Apps: List all the apps you have 

installed. 

Shared with me: Lists the content 

that are shared with you (we will 

share dashboards in a later section). 

Workspaces: Lists all the workspaces 

you are assigned. By default, you are 

assigned My Workspace. 

5. Select the down arrow next to My 

Workspace. Notice DASHBOARDS, 

REPORTS, WORKBOOKS and DATASETS 

sections. Let’s import a Power BI Desktop 

file and create dashboards. 

My Workspace is your personal 

workspace. We need to create a 

workspace where we can collaborate 

with team members and distribute 

content to end users. Let’s create a 

workspace. 

6. In the left panel, select Workspaces -> 

Create app workspace. Create an app 

workspace dialog opens. 

Note: Creating workspace is a Pro 

feature. If you do not have Pro license, 

please choose the trial option.  

7. In the Create an app workspace, select 

Upload Image. 

8.  File browser dialog opens. Browse to 

/DIAD/Data folder. Select 

VanArsdel_WSLogo file. 

9. In Name your workspace text area, 

enter DIAD_<youremailaddress>. 

Note: you are entering your email 

address as part of the workspace name 

to keep it unique. 

10. In Description text area, enter “This 

is DIAD workspace”. 

11. Select Save to create the workspace. 
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Notice you are now navigated from My 

Workspace to the workspace you just 

created. You are in the Welcome screen 

with options to discover or create 

content.  

Discover content has options to connect 

to apps that are shared by your 

organization or the online services. 

Create new content has options to 

connect to Files, Databases and 

Dataflows.  

There are two options to publish the 

Power BI Desktop report we created. 

• Get option under Files. 

• Publish from Power BI Desktop. 

We are going to use the 2nd option. 

 

Let’s publish the report to Power BI 

Service and then we will come back to 

the browser. 

12. Navigate to /DIAD/Reports folder. 

13. Open DIAD Final Report.pbix file.  

14. From the ribbon select Home -> 

Publish. 

15. If you have not already logged into 

Power BI, a Sign in dialog opens. Please 

sign in. 

16. Once you are signed in, Publish to 

Power BI dialog opens. Select 

DIAD_<youremailaddress> from the 

dialog. 

17. Click Select. 

 

 

Publishing to Power BI dialog opens. 

Once completed, a success message is 

displayed. 

18. Select Got it to close the dialog. 

 

Now we have published the report to 

Power BI service. Let’s navigate back to 

the browser and start exploring. 
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Once you are in the browser, in the left 

panel notice under  

DIAD_<youremailaddress>, you will see 

REPORTS -> DIAD Final Report and 

DATASETS -> DIAD Final Report. 

  
 

 

Power BI Service – Building Dashboard  

In this section, we will create a 

dashboard that will combine data from 

the Market Share report as well as Social 

report.  

 

At the end of the section, we will create a 

dashboard that looks like the screenshot. 
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Let’s start with exploring the report. 

19. From the left menu, select REPORTS -

> DIAD Final Report. You will be 

navigated to the report you just 

uploaded. 

20. In the map visual, enable drill down 

by hovering over the visual.  

21. Select the down arrow on the top 

right corner of the visual. 

22. Select Australia to drill down to State 

level.  

23. In the map visual, disable drill mode 

by selecting the down arrow on the top 

right corner of the visual. 

24. Select the bubbles on different 

states and notice that as you select the 

states, other visuals get cross filtered. 

The behavior is like that of Power BI 

Desktop. 

25. Select the top arrow on the top left 

corner to drill up to Country level. 
 

26. Hover over the bubble chart on the 

bottom right of the screen. 

27. Select Focus mode icon so the visual 

fits in the canvas. 

28. Select Extreme from the legend. This 

will highlight the performance of Extreme 

segment over time. Notice the spike in 

2018. 

29. Select the Play axis on the bottom 

left of the screen. This will show the 

revenue and % growth of each Product 

Segment over time. 

30. Select Extreme from the legend again 

to remove the filter. 

31. Select Back to Report on the top left 

to navigate back to report view. 
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Let’s pin visuals to the dashboard. 

32. Hover over VanArsdel Market Share 

card visual. 

33. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

34. We do not have a dashboard yet. 

Let’s create one. With New dashboard 

selected, enter VanArsdel in the text box. 

35. Select Pin. 

 

Notice alert messages are displayed 

stating the dashboard is ready to view. 

 

Notice in the left panel, VanArsdel 

Dashboard is created under 

DASHBOARDS. 

 

36. From the left panel, select 

DASHBOARDS -> VanArsdel. 

Notice the VanArsdel Market Share tile is 

pinned to the dashboard. 

37. Click on VanArsdel Market Share, 

notice you are navigated to the report.  

 

Tiles in dashboard are not interactive.    

38. Hover over % Growth by 

Manufacturer visual. 

39. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

40. Make sure VanArsdel is selected in 

the dropdown. 

41. Select Pin. 
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42. Close out alert dialogs. 

43. Hover over Revenue by Year and 

Manufacturer visual. 

44. Select the pin icon on the top right of 

the visual. Pin to dashboard dialog opens. 

45. Make sure VanArsdel is selected in 

the dropdown. 

46. Select Pin. 

 

47. Close out alert dialogs. 

48. Navigate to By Manufacturer page. 

49. From the top right corner, select the 

down arrow. Notice manufacturer slicer 

displays. 

50. Select VanArsdel from the slicer. This 

will filter the visuals. 

51. From the top right corner, select the 

up arrow. Notice manufacturer slicer 

collapses. 

 

52. Pin the gauge visual to the 

dashboard. 

53. Pin Revenue by Country visual to the 

dashboard. 

54. Close out alert dialogs. 

 

Note: VanArsdel filter is applied to the 

tile that is pinned to the dashboard. 
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55. From the left panel, select 

DASHBOARDS -> VanArsdel. 

Notice all the visuals are pinned as tiles 

to the dashboard.  

You will see the visuals on the dashboard 
like the screenshot. 

 

Each visual on the dashboard is called a 
tile. The tiles represent the data chosen 
and will be kept up to date as the data in 
the data model updates. Tiles are not 
interactive. 

 

Let’s organize the dashboard now. 

 

56. Select and move the gauge tile as 

shown in the screenshot. 

57. Select the bottom right corner of the 

tile and move it diagonally to change the 

image size. 

 

Tiles can be of various sizes (1x1 to 5x5). 

Drag the tile using the bottom right 

corner to resize. As you are dragging, 

note the gray shadow which indicates the 

size of the tile when you stop dragging. 
 

58. From the top menu, select Add tile. 

Add tile dialog opens. 

59. Select Image as the source. 

60. Select Next. 

61. In URL text box, enter 

https://raw.githubusercontent.com/Char

lesSterling/DiadManu/master/Vanarsdel.

png  

Note: URL is case sensitive. 

 

62. Select Apply. 

 

Notice a new tile with VanArsdel logo is 

added to the dashboard. 

 

https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
https://raw.githubusercontent.com/CharlesSterling/DiadManu/master/Vanarsdel.png
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63. Resize and rearrange the tiles as 

shown in the screenshot. 

 

Revenue by Country tile shows Revenue 

by Country for VanArsdel, so let’s rename 

it. 

64. Hover over Revenue by Country tile. 

65. Select the ellipsis on the top right 

corner of the tile. 

66. Select Edit Details. Tile Details dialog 

opens. 

67. Change Title to VanArsdel Revenue. 

68. Select Apply. 

 

It will be nice to have a visual that 

represents Market Share by country. 

Notice on the top of the visual, there is 

an option to Ask a question about your 

data. This is similar to Ask a question in 

the desktop. 

69. In the text box start typing, 

VanArsdel market share. Notice a card 

visual is created. 

70. Continue typing VanArsdel market 

share by country. Notice a bar chart is 

created. 

71. Continue typing VanArsdel market 

share by country as treemap. Notice a 

treemap visual is created. 
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Note: Remember we renamed tables. 

One of the reasons we did it is to make it 

user friendly for Q&A. 

72. From the top right of the screen, 

select Pin Visual. 

73. Pin to dashboard dialog opens. Select 

Pin to pin the visual to VanArsdel 

dashboard. 

74. Close the alert dialogs. 

75. Select Exit Q&A to navigate back to 

the dashboard. 

 

Notice the visual is added as tile to the 

dashboard. Clicking on the tree map 

visual will navigate you back to the Q&A 

section. 
 

Power BI quickly searches different 

subsets of your dataset while applying a 

set of sophisticated algorithms to 

discover potentially-interesting insights. 

You can run insights against a dataset or 

dashboard tile. Let’s generate insights on 

a dashboard tile. When we run insights 

on a dashboard tile, instead of searching 

for insights against an entire dataset, 

search is narrowed to the data used to 

create a single dashboard tile. This is 

often referred to as scoped insights. 

 

76. Hover over the line chart on the 

dashboard. 

77. Select the ellipsis on the top right 

corner. 

Select View Insights. 
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You will be navigated to Focus mode for 

the line chart.  

78. Scroll on the Insights panel to review 

the various insights Power BI can 

generate. Notice that there is an option 

to pin insight visuals to the dashboard. 

79. Click on Exit Focus mode on the top 

left to navigate back to the dashboard. 

 

We want to be notified when VanArsdel’s 

Market Share goes above or below a 

threshold. We can set up alerts to 

achieve this. 

80. Hover over VanArsdel Market Share 

tile. 

81. Click on the ellipsis on the top right 

corner of the tile. 

82. Select Manage alerts. Manage alerts 

dialog opens. 

83. Select Add alert rule dialog. 

Notice you can add Above and Below 

threshold and notification frequency can 

be set. 

This is an introduction to managing 

alerts. Complete functionality is not 

covered in this lab.   

84. Select Cancel to close the dialog. 

85. Select Don’t Save.  
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86. Click on VanArsdel Market Share tile 

to navigate to the report. 

87. In map visual, right click on Australia 

bubble and select Drillthrough -> By 

Manufacturer. 

88. You will be navigated to By 

Manufacturer page of the report with 

Australia filter applied to the report page. 

 

89. Hover over matrix visual.  

90. Select focus mode icon on the top 

right corner of the visual. 

91. From the top menu, select Explore -> 

Show Next Level. Notice now data is at 

Product Segment level. 

From the top menu, select Explore -> 

Drill up. 

 

92. This time from the top menu, select 

Explore -> Expand to next level. Notice 

now data is at Segment level but laid out 

as a hierarchy.  

93. Select Back to Report to navigate 

back to the report view. 

 

94. Notice all the functionality that is 

available in Power BI Desktop is available 

in the service. E.g. Show Data, See 

Records, etc. 
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95. From the top menu, select View and 

enable Bookmark pane. Bookmark pane 

opens on the right. There are 2 options, 

Personal bookmarks and Report 

bookmarks. 

Report bookmarks: are the bookmarks 

report author created (we did this in 

Power BI Desktop). 

Personal bookmarks: Report consumer 

can create their own bookmarks. 

96. Select View in the Report bookmarks 

pane. 

Notice you can view and navigate 

through the bookmarks using the arrow 

in the bottom of the screen. The behavior 

is like in Power BI Desktop. 

Select Exit in Bookmark pane to close it. 

 

Power BI provides an option to get quick 

insights into the complete dataset. 

 

97. In the left panel, hover over 

DATASETS -> DIAD Final Report. 

98. Select the ellipsis. 

99. Select Quick Insights. 

 

It might take a few minutes for the 

insights to be created. Once insights are 

ready a message appears of the top right 

corner. 

 

100. Select View insights. 

101.   
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A quick insights report is displayed based 

on the dataset. This provides insights into 

data you may have missed and helps to 

get a quick start with creating 

dashboards. 

Hovering over each report provides an 

option to Pin it to a dashboard. 

As you scroll down, notice there is a bar 

chart % Growth BY PRODUCT. Might be 

interesting to analyze this. 

 

Marketing team has captured data from 

social networks and built a Power BI 

report. Let us publish this report to 

Power BI service and analyze the data. 

102. From the bottom of the left panel, 

select Get Data. 

103. Get Data screen is displayed. Under 

Import or Connect to Data, select Files. 

 

 

104. From Get Data -> Files screen select 

Local File. 

105. File browser dialog opens. Navigate 

to /DIAD/Reports folder. 

106. Select Social.pbix file and click 

Open. 
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107. Once the report is published, an 

alert message appears. Close the alert 

dialog. 

In the left panel, notice under REPORTS, 

we see Social. 

108. Select REPORTS -> Social to be 

navigated to the Twitter page of the 

Social report.  

Marketing team has captured the 

retweets of #VanArsdel. Notice there is a 

spike in 2018. Does this have any 

correlation to the spike in sales in 

Australia? Let’s investigate. 

Hover over Retweets visual and click on 

Focus mode icon. 

 

109. Enable drill mode. 

110. Drill down to month level for the 

year 2018. 

Notice there is a big spike in retweets in 

the last few months of 2018. If you 

remember from the demo this is the 

reason for the increase in sales. 

111. Drill back up to Year level. 

112. Select Back to Report to navigate 

back to report view. 

 

113.  

 

Let’s add this visual to our Dashboard 

 

114. Hover over Retweets visual. 

115. Select the pin icon on the top right 

of the visual. Pin to dashboard dialog 

opens. 

Pin the visual to VanArsdel dashboard.  
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116. Close the alert dialogs. 

117. From the left panel, select 

DASHBOARDS -> VanArsdel to navigate 

to the dashboard. 

Notice two new tiles are added to the 

dashboard. The retweets tile we just 

pinned and a default tile that is added 

when a new dataset is added. 

118. Hover over Social.pbix tile. 

119. Click on the ellipsis on the top right 

corner. 

120. Select Delete tile to remove the tile. 

 

121. Notice you can have tiles from 

multiple reports and Q&A section on a 

single dashboard. 

 

 

122. Navigate back to VanArsdel 

dashboard. 

123. Notice on the top right of the menu 

bar, there is options to add this 

dashboard to the favorites. Click on 

Favorite option. 

124. Now click on Favorite in the left 

panel. Notice the dashboard is added to 

the list. This is an easy way to access all 

your favorite or most used dashboards 

quickly. 

 Click on the ellipsis on the top right 

corner of the page, next to Share option. 

Notice there are options to duplicate, 

print and refresh dashboard. 

 

On the top right corner of the screen, 

next to Favorite, there is Set as featured 

option. Set as Featured dashboard sets 

the dashboard as the default dashboard 

that user will land on every time they 

login. 

 

125. In the left panel, select VanArsdel 

Dashboard.  
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126. Select Set as Featured from the top 

menu.  

127. A confirmation dialog is displayed. 

Select Set as Featured Dashboard. This 

sets VanArsdel as the featured/default 

dashboard. 

128. Navigate back to VanArsdel 

dashboard. 

129. If you have not already done so, 

move the visuals to look like the 

screenshot. 

You have successfully built a dashboard. 
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Power BI Service – Collaboration and Distribution  

You have built the dashboard and ready 
to get feedback and collaborate with 
your team members. 

 

1. From the left panel, select 

Workspaces. 

2. Select the ellipsis next to 

DIAD_<youremailaddress>. 

3. Select Workspace access. 

4. Access dialog opens. You can enter the 

email addresses of the colleagues you 

want to collaborate with. 

Each user can belong to one of 3 roles: 

 
Contributor Add/edit/delete content within 

workspace. 

Member Everything a Contributor can 

do. 

Re-share. Publish & update 

Apps. 

Admin Everything a member can do. 

Can change/delete workspace. 

Can add Admins. 

 

 

5. Select the role and select Add. 

6. Once you finish adding your colleagues 

and select Close. 

Note: you can ask your colleague to login 

and access the workspace. 

 

 
 

 

Now let’s share the content we created 

with the report viewers/consumers. We 

need to publish an app to do this. 

An App can include multiple dashboards 

and reports. 

  

7. In the left panel select 

DIAD_<youremailaddress> workspace. 

8. In the Dashboard page, notice there is 

an option INCLUDED IN APP, to include 

the Dashboard in the App. 
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9. Navigate to Reports page. 

10. Notice there is an option INCLUDED 

IN APP to include the Reports in the App. 

If you have reports and dashboards in 

your workspace that you do not want to 

share with report viewers, you can 

uncheck this box. 

In our case we would like to include the 2 

reports, so we will leave the boxes 

checked. 

 

11. In the left panel select 

DIAD_<youremailaddress> workspace. 

12. From the top right corner of the top 

menu select Publish app. 

 

13. In the Setup page, enter “This is 

DIAD app” in the description field. 

14. Click on Navigation page. 

  

15. From the dropdown select VanArsdel 

(dashboard).  

When a user accesses the DIAD app, we 

want them to land on the VanArsdel 

dashboard. 

16. Navigate to Permissions page. 
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17. Enter the email addresses of the 

users or groups you want to give access 

to. 

18. On the bottom right corner, select 

Publish App. 

19. Ready to publish dialog appears. 

Select Publish. 

20. Once the App is published a success 

dialog appears. 

 

You can copy the link to the App and 

share it with the individuals via email. But 

a better way for report viewers to 

consume the App is by logging onto 

Power BI Service and registering the App. 

Let’s impersonate a report viewer. 

21. From the left menu, select Apps. 

22. Select Get Apps. 

 

23. AppSource dialog opens. You will 

notice DIAD_<youremailaddress> App 

listed. Select Get it now. 

 

This is a one-time registration. Going 

forward when you select Apps in the left 

panel, you will see 

DIAD_<youremailaddress> app in the list 

of Apps you have registered. 

 

24. Click on DIAD_<youremailaddress> 

tile. 

You will be navigated to VanArsdel 

dashboard.  
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References 
 

Dashboard in a Day introduces you to some of the key functionalities available in Power BI. In the ribbon 

of Power BI Desktop, the Help section has links to some great resources to help you as needed. 

 

 

Here are a few more references that will help you with your next steps with Power BI. 

 

Getting started: http://powerbi.com  

Power BI Desktop:  https://powerbi.microsoft.com/desktop  

Power BI Mobile: https://powerbi.microsoft.com/mobile  

Community site https://community.powerbi.com/ 

Power BI Getting started support page: https://support.powerbi.com/knowledgebase/articles/430814-

get-started-with-power-bi  

Support site https://support.powerbi.com/  

Feature requests https://ideas.powerbi.com/forums/265200-power-bi-ideas 

Power BI edX course https://www.edx.org/course/analyzing-visualizing-data-power-bi-microsoft-dat207x-
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FULL FEATURE FUNCTIONALITY AND MAY NOT WORK THE WAY A FINAL VERSION MAY WORK. 

WE ALSO MAY NOT RELEASE A FINAL VERSION OF SUCH FEATURES OR CONCEPTS.  YOUR 

EXPERIENCE WITH USING SUCH FEATURES AND FUNCITONALITY IN A PHYSICAL ENVIRONMENT 

MAY ALSO BE DIFFERENT. 

FEEDBACK.  If you give feedback about the technology features, functionality and/or concepts described 

in this demo/lab to Microsoft, you give to Microsoft, without charge, the right to use, share and 

commercialize your feedback in any way and for any purpose. You also give to third parties, without 

charge, any patent rights needed for their products, technologies and services to use or interface with any 

specific parts of a Microsoft software or service that includes the feedback. You will not give feedback that 

is subject to a license that requires Microsoft to license its software or documentation to third parties 

because we include your feedback in them. These rights survive this agreement. 

MICROSOFT CORPORATION HEREBY DISCLAIMS ALL WARRANTIES AND CONDITIONS WITH 

REGARD TO THE DEMO/LAB, INCLUDING ALL WARRANTIES AND CONDITIONS OF 

MERCHANTABILITY, WHETHER EXPRESS, IMPLIED OR STATUTORY, FITNESS FOR A PARTICULAR 

PURPOSE, TITLE AND NON-INFRINGEMENT.  MICROSOFT DOES NOT MAKE ANY ASSURANCES 

OR REPRESENTATIONS WITH REGARD TO THE ACCURACY OF THE RESULTS, OUTPUT THAT 

DERIVES FROM USE OF DEMO/ LAB, OR SUITABILITY OF THE INFORMATION CONTAINED IN THE 

DEMO/LAB FOR ANY PURPOSE. 

DISCLAIMER 

This demo/lab contains only a portion of new features and enhancements in Microsoft Power BI. Some of 

the features might change in future releases of the product. In this demo/lab, you will learn about some, but 

not all, new features. 

 

 

 

 

 

 

 

 

 

 

 

 

 

   


